Jump to content

مشکلات نصب و ارتقای نسخه 2.3.0.2 اپن کارت پارسی


Recommended Posts

  • OpenCart Staff

با عرض سلام خدمت تمامی کاربران گرامی سایت اپن کارت پارسی در این تاپیک مشکلات کاربران و تغییراتی که در نسخه 2.3.0.2 داده می شود به اطلاع شما خواهد رسید....لطفا مشکلات خودتون رو در این تاپیک مطرح نمایید. با تشکر

 

  • Excited 1
Link to comment
Share on other sites

  • OpenCart Staff

با سلام خدمت تمامی کاربران اپن کارت پارسی

حل مشکل بخش مدیریت - افزونه ها - ماژول ها  = نسخه جدید در مسیر بخش دریافت نسخه 2.3.0.2 اپن کارت اصلاح و جایگذاری شد

از تمامی کاربران که نسخه را دانلود می کنند اگر مشکلاتی در این نسخه (2.3.0.2) مشاهده نموده اید لطفا در این تاپیک مطرح کنید تا مشکل بررسی و حل بشه

موفق و موید باشید

----------------------------

تاریخ 22 شهریور ماه 1395

1- حذف موارد اضافی از ماژول ها و پرداخت ها در بخش سایت و مدیریت

2- تغییر ترجمه بعضی از لغات در بخش مدیریت

نسخه جدید در مسیر دریافت اپن کارت 2.3.0.2 در انجمن قرار گرفت

در ادامه عید قربان را خدمت تمامی کاربران این انجمن و مسلمانان جهان تبریک عرض می کنم

  • Thankful 1
Link to comment
Share on other sites

یا سلام و خسته نباشید و ضمن تشکر فراوان از زحمت ها

من تو قسمت پرداخت ها ماژول جدید مثل درگاه بانک و یا راشاپی را درست نصب کردم ولی تو قسمت تنظیمات که میخوام فعالشون کنم اجازه دسترسی بهم نمیده ورژن جدیدی را هم که امشب گذاشتید نصب کردم بازم همینجوره لطفا راهنمایی کنید ممنونم

erorre.jpg

Link to comment
Share on other sites

  • Administrators
در 6 دقیقه قبل، arian_piper گفته است :

ورژن جدیدی را هم که امشب گذاشتید نصب کردم بازم همینجوره

درود

دقت کنید برای ورژن 2.3.0.2 پلاگین های جاری قابل نصب نیستن و نیاز به اصلاح کردن است که به زودی این پلاگین هم برای این ورژن اصلاح میشود

  • Love 1
  • Confused 1
Link to comment
Share on other sites

ممکنه تقاضا کنم نسخه هایی که بر سایت قرار داده می شن سعی بشه کمترین تغییر رو نسبت به نسخه اصلی در سایت داشته باشه؟ درسته همه این تغییرات باعث بهبود اپن کارت می شه اما در عین حال مشکلات بعدی رو هم به دنبال داره

 

در صورتی که تصمیم بر این هست که تغییرات زیاد باشه خیلی عالی می شه اگه دو نسخه باشه یکی با کمترین تغییر و یکی نسخه مخصوص انجمن

 

و پیشنهاد دیگه هم اینکه کاش یک ریپوزیتوری گیت های ایجاد می کردید تا هر کسی موردی رو اصلاح می کرد بتونه راحتتر اون رو انتقال بده بهتون،

Link to comment
Share on other sites

  • Administrators

@nasser.man , @arian_piper

دقت کنید و اگاه باشید تنها تغییری که ما دادیم شمسی کردیم و پرداخت های اضافی رو حذف کردیم همچنین اینکه در مورد مطلب پیشین که چرا سازگار نیست به این خاطر هست که کلا بخش ماژول متحول شده و این تغییرات از سمت توسعه دهندگان اصلی اپن کارت بوده بر خلاف سایرین که عمدتا بخش هایی رو دستکاری میکنن وب سایت اپن کارت با طعم پارسی هیچ گونه تغییرات غیر اصولی در هسته نمی دهد

  • مثبت 1
  • Thankful 1
  • Excited 1
Link to comment
Share on other sites

من مشکلم یه مقدار حاد تر شد همینطور که تو اسکرین شات ملاحظه میکنید الان که یکی از درگاه های پرداخت رو انتخاب کردم  دیگه گزینه ادامه خریدی در کار ندارم

erorre2.jpg

Edited by arian_piper
Link to comment
Share on other sites

  • OpenCart Staff
در در 23 شهریور 1395 در 00:09، arian_piper گفته است :

من تو قسمت پرداخت ها ماژول جدید مثل درگاه بانک و یا راشاپی را درست نصب کردم ولی تو قسمت تنظیمات که میخوام فعالشون کنم اجازه دسترسی بهم نمیده ورژن جدیدی را هم که امشب گذاشتید نصب کردم بازم همینجوره لطفا راهنمایی کنید

کاربر گرامی همان طور که آقای کوهپایه (موسس سایت) نیز اشاره کردند نسخه 2.3.0.2 متفاوت با نسخه های دیگر می باشد و باید تغییرات ماژول ها را برای این نسخه جداگانه انجام گیرد.... ماژول بانک ها بزودی در بخش فروشگاه قرار خواهد گرفت....

در در 23 شهریور 1395 در 00:44، nasser.man گفته است :

ممکنه تقاضا کنم نسخه هایی که بر سایت قرار داده می شن سعی بشه کمترین تغییر رو نسبت به نسخه اصلی در سایت داشته باشه؟

کاربر گرامی تغییرات در نسخه 2.3.0.2 موجود در انجمن زیاد نیست و بیشتر همان طور که آقای کوهپایه (موسس سایت) گفتند بیشتر حذف موارد پرداختی و حمل و نقل اضافه هست (چون کاربران ایرانی نیاز ندارند - مثل پرداخت با کارت های پی پال - یا حمل و نقل ویژه کشور ایالات متحده --- و موارد دیگر )

در در 23 شهریور 1395 در 00:44، nasser.man گفته است :

و پیشنهاد دیگه هم اینکه کاش یک ریپوزیتوری گیت های ایجاد می کردید تا هر کسی موردی رو اصلاح می کرد بتونه راحتتر اون رو انتقال بده بهتون،

خیلی خوب --- حتما از این پیشنهاد شما استفاده خواهد شد. :x

در در 23 شهریور 1395 در 02:36، arian_piper گفته است :

من مشکلم یه مقدار حاد تر شد همینطور که تو اسکرین شات ملاحظه میکنید الان که یکی از درگاه های پرداخت رو انتخاب کردم  دیگه گزینه ادامه خریدی در کار ندارم

کاربر گرامی تغییری در ساختار داده اید (ماژول خاصی را نصب نموده اید)

در در 23 شهریور 1395 در 12:08، nasser.man گفته است :

روش پرداخت نداره من نتونستم تا اخر ثبت سفارش برم

کاربر گرامی روش پرداخت در بخش مدیریت منوی افزونه ها از گزینه های نوع افزونه گزینه پرداخت را انتخاب نمایید و هر کدام از پرداخت هایی که می خواهید بر روی سیستم فروشگاهی نصب نمایید. به طور پیش فرض پرداخت در هنگام تحویل فعال می باشد.

  • Excited 1
Link to comment
Share on other sites

الان اخرین ورژن و نصب کردم

باز هم مشکل عدم دسترسی دارم و جالب اینه که مثلا اگر ماژولی را فعال کنم برام مینویسه اجازه دسترسی ندارید ولی ماژول فعال میکنه یه مشکل بزرگتر تو ورژن قبلی هم همین مشکل و داشتم

Notice: Error: Could not load template /home/jehat/kharidkhooneh.ir/catalog/view/theme/default/template/default/template/common/success.tpl! in /home/jehat/kharidkhooneh.ir/system/storage/modification/system/library/template/php.php on line 23

اولش نبود چندتا خرید سوری هم کردم خوب بود  بدون هیچ تغییری یوهویی دیگه بجا ثبت سفارش....

اگه دقت کنید /default/template یکیش اضافیه

Link to comment
Share on other sites

  • OpenCart Staff
در 10 ساعت قبل، arian_piper گفته است :

من هیچ افزونه ای به غیر از دو تا درگاه راشا پی و درگاه بانک نصب نکردم

کاربر گرامی آیا این دو درگاه پرداخت که استفاده می کنید برای نسخه 2.3.0.2 یکسان سازی شده است یا برای نسخه های قبل از آن می باشد؟؟؟

آیا افزونه و درگاهی بانکی که استفاده می کنید فایلهای Vqmod یا ocmod دارد؟؟؟ (بهتر است افزونه Vqmod برای نسخه 2.3.0.2 موجود در انجمن را در سایت خود نصب نمایید)

اگر محصولات زیادی در سایت خود دارید قبل از انجام هر کاری از اطلاعات و دیتابیس خود پشتیبان تهیه کنید

 

در 10 ساعت قبل، arian_piper گفته است :

در تو قسمت مدیریت پرداخت ها هم افزونه پرداخت نقدی فعاله ولی نشون نمیده

آخرین نسخه را در سیستم لوکال نصب کردید یا هاست !!! --- اگر بر روی هاست هستش دسترسی به بنده بدهید بررسی کنم ---- مجدداً آخرین نسخه را از قسمت دریافت نسخه 2.3.0.2 دانلود و در مسیر هاست انتقال دهید سپس در بخش مدیریت تغییرات و اصلاحات بروزرسانی را انجام دهید...

در 6 ساعت قبل، arian_piper گفته است :

باز هم مشکل عدم دسترسی دارم و جالب اینه که مثلا اگر ماژولی را فعال کنم برام مینویسه اجازه دسترسی ندارید ولی ماژول فعال میکنه

کدام ماژول را در بخش مدیریت نصب می کنید!!! لطفاً نسخه جدید 2.3.0.2 را مجدداً از انجمن دانلود و در مسیر سایت فروشگاهی قرار دهید و عملیات آپدیت (بروزرسانی اپن کارت) را انجام دهید

از Vqmod استفاده می کنید... (بهتر است نسخه VQmod برای اپن کارت 2.3.0.2 موجود در انجمن را دانلود و نصب نمایید)

قبلش باید فایلهای Vqmod خود را غیرفعال یا حذف نمایید

من در سایت شما مراحل تسویه حساب را انجام دادم مشکلی نبود .... !!!! (چند بار این کار را انجام می دهید مشکل ایجاد می شود.... آیا افزونه خاصی نصب کرده اید!!!!)

  • Thankful 1
  • Like 1
Link to comment
Share on other sites

الان که مراحل تسویه مشکلی نداره بخاطر اینه که از پوشه common واقع در

/home/jehat/kharidkhooneh.ir/catalog/view/theme/default/template/default/template

یه کپی گرفتم و  در

/home/jehat/kharidkhooneh.ir/catalog/view/theme/default/template/default/template/default/template

قرار دادم

Link to comment
Share on other sites

  • OpenCart Staff
در در 1395/06/24, 22:29:30، arian_piper گفته است :

الان که مراحل تسویه مشکلی نداره بخاطر اینه که از پوشه common واقع در

در مسیر سایت تون الان ثبت سفارش زدم ---- مشکلی نداشت

فروشگاه را در روت نصب کرده اید!!!!

فایل config.php را در مسیر روت سایت با ادیتور سی پنل هاست تون باز کنید

خطوط مربوط به آدرس دهی را با دقت مشاهده نمایید

از هاست ابری استفاده می کنید؟؟؟

  • Thankful 1
  • Excited 1
Link to comment
Share on other sites

 

خیر هاست معمولی 

بالاخره بعد از یک هفته فهمیدم کجا کار میلنگه

خود اپن کارت 2.3.0.2 اورجینال هم مشکل داره یا لااقل من باهاش مشکل دارم

برای تست اورجینال زبان انگلیسی را نصب کردم دقیقا اونم مثل ورژن فارسی همین مشکل و داره مثلا صفحه درباره ما را ادیت نمیکنه البته صفحه ادیت را میاره تغییر هم میدم سیو میکنم و پیام با موفقیت تغییر کرد را هم میده ولی هیچ تغییری نمیکنه

Link to comment
Share on other sites

  • OpenCart Staff

اگر نسخه 2.3.0.2 انگلیسی را هم نصب کردید با مشکل مواجه شدید .... راه حل پیشنهادی بنده :

1- نسخه php  که در سایت شما ؟؟؟

2- نصب اپن کارت نسخه 2.3.0.2 را با هاست خود مطرح نمایید!!!!

2- نسخه 1.5.6.4 موجود در بخش دریافت را دانلود و نصب نمایید!!!

3- نسخه 1.5.6.4 انگلیسی رو دانلود و نصب نمایید!!!

4- اگر با نصب نسخه 1.5.6.4 هم مشکل داشتید احتمالا مشکل شما از افزونه های که توسط هاست باید بر روی سرور شما نصب شود می باشد...

5- در هاست دیگری نصب کنید

مخفی کننده

System / Server requirements

These extensions must be enabled for OpenCart to install properly on the web server.

  • Web Server (Apache suggested)
  • PHP 5.3+(1.5.x at least 5.2+)
  • Database (MySQLi suggested)

Required PHP libraries / modules

  • Curl
  • ZIP
  • Zlib
  • GD Library
  • Mcrypt
  • Mbstrings
  • Xml

 

  • مثبت 1
  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
  • Accountable Supervisor

داخل بخش خطا این خطا ها هست

2016-10-09 11:37:35 - MOD: Modification Default

FILE: system/engine/action.php
REGEX: ~(require|include)(_once)?\(([^)]+)~
LINE: 41
 

 

Edited by gh.m
اصلاح کد برای نمایش کوتاه در انجمن
  • Like 1
Link to comment
Share on other sites

  • OpenCart Staff

کاربر گرامی aman دقت داشته باشید بیشتر کدهای نمایش داده شده صرفاً جهت اطلاع می باشد .... که مثلا در فایل x کد x قرار داده شده .... اگر در کد خطا ها مواردی همچون abort و غیره بود احتمالا کدها در فایل پیدا نشده و جایگزین انجام نشده...

  • Confused 1
  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy